Dedimania forum

Feel free to express yourself on your favorite dedicated related tool.

You are not logged in.

  • Index
  •  » Aseco
  •  » New dedimania records are not uploaded

#1 2014-12-23 13:42:54

alla_wackba
tm2:alla_wackba
New member
Registered: 2014-12-23
Posts: 1

New dedimania records are not uploaded

Hi, I am using the latest version of the ManiaPlanet Dedicated Server in combination with the latest version of Xaseco 2. The records eyepiece plugin for Xaseco comes with a Dedimania plugin to show the world records as a widget. Everything works fine, except for the fact, that new Dedimania records driven on my server are not uploaded. I also have a TMU server using fufi widgets and fufi menu where new records are automatically uploaded. Can anyone help me? Did I forget to configure something for TM2?

edit: my log file
[XAseco2] PHP Version is 5.3.28 on WINNT
[XAseco2] Load settings [config.xml]
[XAseco2] Load default window style [styles/Card.xml]
[XAseco2] Load default panel background [panels/PanelBGCard.xml]
[XAseco2] Load admin/ops lists [adminops.xml]
[XAseco2] Load banned IPs list [bannedips.xml]
[XAseco2] Load plugins list [plugins.xml]
[XAseco2] Load plugin [plugin.localdatabase.php]
[XAseco2] Load plugin [plugin.rounds.php]
[XAseco2] Load plugin [chat.admin.php]
[XAseco2] Load plugin [chat.help.php]
[XAseco2] Load plugin [chat.records.php]
[XAseco2] Load plugin [chat.records2.php]
[XAseco2] Load plugin [chat.recrels.php]
[XAseco2] Load plugin [chat.dedimania.php]
[XAseco2] Load plugin [chat.players.php]
[XAseco2] Load plugin [chat.players2.php]
[XAseco2] Load plugin [chat.wins.php]
[XAseco2] Load plugin [chat.laston.php]
[XAseco2] Load plugin [chat.lastwin.php]
[XAseco2] Load plugin [chat.stats.php]
[XAseco2] Load plugin [chat.server.php]
[XAseco2] Load plugin [chat.songmod.php]
[XAseco2] Load plugin [chat.me.php]
[XAseco2] Load plugin [plugin.mxinfo.php]
[XAseco2] Load plugin [plugin.map.php]
[XAseco2] Load plugin [plugin.checkpoints.php]
[XAseco2] Load plugin [plugin.dedimania.php]
[XAseco2] Load plugin [plugin.rasp.php]
[XAseco2] Load plugin [plugin.rasp_jukebox.php]
[XAseco2] Load plugin [plugin.rasp_chat.php]
[XAseco2] Load plugin [plugin.rasp_karma.php]
[XAseco2] Load plugin [plugin.rasp_nextmap.php]
[XAseco2] Load plugin [plugin.rasp_nextrank.php]
[XAseco2] Load plugin [plugin.rasp_votes.php]
[XAseco2] Load plugin [plugin.chatlog.php]
[XAseco2] Load plugin [plugin.style.php]
[XAseco2] Load plugin [plugin.panels.php]
[XAseco2] Load plugin [plugin.donate.php]
[XAseco2] Load plugin [plugin.musicserver.php]
[XAseco2] Load plugin [plugin.uptodate.php]
[XAseco2] Load plugin [jfreu.plugin.php]
[XAseco2] Load plugin [mistral.idlekick.php]
[XAseco2] Load plugin [plugin.records_eyepiece.php]
[XAseco2] Load plugin [plugin.personal_best_medals.php]
[12/23,15:44:16] Try to connect to MP dedicated server on 127.0.0.1:5004 timeout 180s
[12/23,15:44:16] Try to authenticate with login 'SuperAdmin' and password '...'
[12/23,15:44:16] Waiting for dedicated server to reach status 'Running - Play'...
[12/23,15:44:16] Status: Running - Synchronization
[12/23,15:44:17] Status: Running - Play
[12/23,15:44:17] Connection established successfully !
[12/23,15:44:17] [LocalDB] Load config file [localdatabase.xml]
[12/23,15:44:17] [LocalDB] Try to connect to MySQL server on 'localhost' with database 'xaseco2'
[12/23,15:44:18] [LocalDB] MySQL Server Version is 5.5.40
[12/23,15:44:18] [LocalDB] Checking database structure...
[12/23,15:44:18] [LocalDB] ...Structure OK!
[12/23,15:44:18] [RASP] Loading config file [rasp.xml]
[12/23,15:44:18] [RASP] Checking database structure...
[12/23,15:44:18] [RASP] ...Structure OK!
[12/23,15:44:18] [RASP] Cleaning up unused data
[12/23,15:44:18] Load default admin panel [panels/AdminRightCorner.xml]
[12/23,15:44:18] Load default donate panel [panels/DonateBelowCPList.xml]
[12/23,15:44:18] Load default records panel [panels/RecordsRightCorner.xml]
[12/23,15:44:18] Load default vote panel [panels/VoteBottomCenter.xml]
[12/23,15:44:18] ************* (Dedimania) *************
[12/23,15:44:18] * Dataserver connection on Dedimania ...
[12/23,15:44:18] * Try connection on http://dedimania.net:8082/Dedimania ...
[12/23,15:44:19] Webaccess (dedimania.net:8082/Dedimania.8112): send: deflate, receive: deflate
[12/23,15:44:19] * Connection and status ok! (Dedimania.8112)
[12/23,15:44:19] ------------- (Dedimania) -------------
[12/23,15:44:19] Load stats panel [panels/Stats2.xml]
[12/23,15:44:19] Load music server config [musicserver.xml]
[PHP Notice] Undefined index: EYEPIECE_WIDGET on line 321 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: SCORE on line 322 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: POS_X on line 16433 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: POS_Y on line 16433 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: POS_X on line 16437 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: POS_Y on line 16437 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: BACKGROUND_STYLE on line 16439 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: BACKGROUND_SUBSTYLE on line 16439 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: TEXT_COLOR on line 16442 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[PHP Notice] Undefined index: TEXT_COLOR on line 16443 in file F:\Programme\TM2DedicatedServer\xaseco2\plugins\plugin.records_eyepiece.php
[12/23,15:44:20] **********[plugin.records_eyepiece.php/1.0.9.9-MP]**********
[12/23,15:44:20] >> Checking Database for required extensions...
[12/23,15:44:20]    + Found column `Timezone` at table `players_extra`.
[12/23,15:44:20]    + Found column `DisplayWidgets` at table `players_extra`.
[12/23,15:44:20]    + Found column `MostFinished` at table `players_extra`.
[12/23,15:44:20]    + Found column `MostRecords` at table `players_extra`.
[12/23,15:44:20]    + Found column `RoundPoints` at table `players_extra`.
[12/23,15:44:20]    + Found column `TeamPoints` at table `players_extra`.
[12/23,15:44:20]    + Found column `Visits` at table `players_extra`.
[12/23,15:44:20]    + Found column `WinningPayout` at table `players_extra`.
[12/23,15:44:20]    + Found index `Continent` at table `players`.
[12/23,15:44:20]    + Found index `Nation` at table `players`.
[12/23,15:44:20]    + Found index `Wins` at table `players`.
[12/23,15:44:20]    + Found index `UpdatedAt` at table `players`.
[12/23,15:44:20]    + Found index `Score` at table `records`.
[12/23,15:44:20]    + Found index `Score` at table `rs_karma`.
[12/23,15:44:20]    + Found index `Score` at table `rs_times`.
[12/23,15:44:20] >> Updating `MostFinished` counts for all Players...
[12/23,15:44:20] >> Updating `MostRecords` counts for all Players...
[12/23,15:44:20] >> Finished.
[12/23,15:44:20] ***********************************************************
###############################################################################
  XASECO2 v1.03 running on 127.0.0.1:5004
  Name   : Aldebaran
  Game   : ManiaPlanet - Canyon - TimeAttack
  Version: 3.3.0 / 2014-11-24_12_34
  Author : Xymph
###############################################################################
Begin Round
Begin Map
[12/23,15:44:21] [plugin.records_eyepiece.php] Register event "onCheckpoint" to enabled wanted Widgets.
[12/23,15:44:21] map changed [undefined] >> [A01]
[12/23,15:44:21] current record on A01 is 0:25.375 and held by Ѡ

Last edited by tm2:alla_wackba (2014-12-23 13:48:06)

Offline

#2 2015-02-09 22:44:13

knives
tm2:knives81
New member
Registered: 2015-02-09
Posts: 3

Re: New dedimania records are not uploaded

UP ! :p
I have the same problem. Everything seems OK
Records are saved on DB, can get Dedimania records, etc.
But records made on server are not sent to Dedimania.

here are the logs, as you can see, no errors.

[02/09,22:31:33] ************* (Dedimania) *************
[02/09,22:31:33] * Dataserver connection on Dedimania ...
[02/09,22:31:33] * Try connection on http://dedimania.net:8082/Dedimania ...
[02/09,22:31:33] Webaccess (dedimania.net:8082/Dedimania.8100): send: deflate, receive: deflate
[02/09,22:31:33] * Connection and status ok! (Dedimania.8100)
[02/09,22:31:33] ------------- (Dedimania) -------------
[02/09,22:31:33] Load stats panel [panels/Stats2.xml]
###############################################################################
  XASECO2 v1.03 running on 127.0.0.1:5000
  Name   : knives
  Game   : ManiaPlanet - Canyon - TimeAttack
  Version: 3.3.0 / 2014-11-21_14_00
  Author : Xymph
###############################################################################
Begin Map
[02/09,22:31:33] map changed [undefined] >> [A09]
[02/09,22:31:33] currently no record on A09

Last edited by tm2:knives81 (2015-02-10 00:16:01)

Offline

#3 2015-02-10 01:20:03

TX-Slig
slig
Fast author / Dedimania maintainer
From: Traxicoland
Registered: 2006-11-23
Posts: 806
Website

Re: New dedimania records are not uploaded

I suppose that it's still related to this problem (which is supposed to be a temporary fix until Nadeo fixes the info in the validation replay) :
http://dedimania.net/SITE/forum/viewtop … 4492#p4492

Offline

#4 2015-02-10 13:43:52

knives
tm2:knives81
New member
Registered: 2015-02-09
Posts: 3

Re: New dedimania records are not uploaded

Tried it but didn't change.
I looked over the forum, to see if someone has the same problem.
And saw that, the fix is usefull for who has this kind of problem (Validation replay inconsistent) : http://dedimania.net/SITE/forum/viewtop … 4729#p4729

But for me, server not even say this kind of stuff :

[##/##,##:##:##] [Dedimania] player xxxx finished with #### and took the ##. WR place!

just say

[02/09,22:54:32] [LocalDB] player xxxx finished with #### and took the #. LR place!

It's look like, he not even try to send record to dedimania.
Maybe a miss something while configuring ?
It's a fresh install, latest ManiaPlanet server and Xaseco2.

Last edited by tm2:knives81 (2015-02-10 13:44:27)

Offline

#5 2015-02-10 18:44:01

knives
tm2:knives81
New member
Registered: 2015-02-09
Posts: 3

Re: New dedimania records are not uploaded

I think i found out why...
it was really really simple...
But need just a confirmation.
For saving records on dedimania with a non-premium account, record has to be in top 30 ?

Offline

#6 2015-02-10 23:38:41

TX-Slig
slig
Fast author / Dedimania maintainer
From: Traxicoland
Registered: 2006-11-23
Posts: 806
Website

Re: New dedimania records are not uploaded

yes  wink
(15 for stadium2, 30 for others environments)

Offline

  • Index
  •  » Aseco
  •  » New dedimania records are not uploaded

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson