Dedimania forum

Feel free to express yourself on your favorite dedicated related tool.

You are not logged in.

#1 2020-02-27 16:31:57

TMM/// axelalex2
tm2:axelalex2
New member
Registered: 2018-09-08
Posts: 1

ManiaControl still has issues

Hey there,

i'm the new developer of ManiaControl, and currently looking into the issue of the not working DediMania-Plugin of it. As a lot of people have pointed out already, saving records from maps with custom blocks is not working in ManiaControl, while the created requests don't show any sign of that being the case (comparing between a "normal" map and a "custom" map). The only affected call is "dedimania.SetChallengeTimes", all others work just fine.

I even went the extra-mile to get logs from UAseco, which Dedimania-Plugin actually works, and adjusted the ManiaControl-Plugin accordingly to find possible errors, but the request still fails with a "400: Bad Request". As i am nearly out of answers (except for fully rewriting the whole Web-Backend, which can't be really a solution here), i would like to get in closer contact with you about this topic. I have a few example calls, which syntactically look just fine, but fail anyways.

A head-scratching coder,
axelalex2

Offline

#2 2020-03-21 16:43:43

TX-Slig
slig
Fast author / Dedimania maintainer
From: Traxicoland
Registered: 2006-11-23
Posts: 844
Website

Re: ManiaControl still has issues

Hi,

Sorry I come on the forum only very occasionally now...  hmm

The only thing i can suggest is look at the raw xmlrpc data you are going to send before compressing (eventually disable compression and get it from wireshark or other if you can't get it directly in maniacontrol)

Gilles

Offline

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson